Get in touch
Back
Degraded

Email deliverability issues

Started , resolved .

Application Server
Resolved

Email issues resolved

Posted .
Created

We are currently experiencing issues with our Email Service Provider, which is resulting in non-delivery of emails. This outage is expected to continue for a few more hours, unfortunately. We will keep you updated as the situation progresses.

Posted .